Thursday, July 28, 2011

Solaris Commands

Solaris Command:

Version of Solaris:
# uname -r
5.10


#Determine whether package installed or not
# pkginfo -i SUNWarc
system SUNWarc Lint Libraries (usr)

# pkginfo -i SUNWsprox
ERROR: information for "SUNWsprox" was not found




# prtconf|grep "Memory size"
Memory size: 536 Megabytes
# /usr/sbin/swap -s

total: 218988k bytes allocated + 55636k reserved = 274624k used, 721404k available

# /bin/isainfo -kv

32-bit i386 kernel modules


Enable Network Card:

Enable the network card
#ifconfig e1000g0 plumb

Then issue the ifconfig -a Command

#ifconfig e1000g0 192.168.0.106 netmask 255.255.255.0 up

#ifconfig -a

Configuring Virtual interface

#ifconfig e1000g0:1 172.40.30.4 netmask 255.255.0.0 up


SSH Configuration User Equivalence Failed:

Workaround:

#mkdir -p /usr/local/bin
# ln -s /usr/bin/ssh /usr/local/bin
# ln -s /usr/bin/scp /usr/local/bin

No comments: